Grompp error

GROMACS version:
GROMACS modification: Yes/No
Here post your question


I have used the OPLS force field to create a ligand topology file. In grompp step, I got an Atom type F (Fluorine) not found. I have an F atom in my gro file.

How to rectify the error?

OPLS atom types are typically of the form “opls_XXX” so calling “F” as an atom type (which is in the topology, not the coordinate file) is unusual. How did you generate the topology for this species?

Hello Sir,

Thanks a million for your reply.

Since I can’t error (UNK error) in ligpar gen tool, I used the prodrug tool for ligand topology preparation. I have also attached my ligand.pdb file for your perusal. Kindly have a look in it.

You can’t kid and match force fields. And PRODRG produces probably terrible topologies. Don’t use it, even for simulations with GROMOS (for which it was designed). Pick a force field that covers the species you need, and stick with it. You can’t take parts from one and mix them with parts of another.

Did you also install BOSS for ligpargen? If so did you set the location of BOSS tool to $BOSSdir

Thanks a million for your reply sir.

Since my protein has calcium metal ion, I tried force field like Amber, and Chaarm. But I couldnt run sucessfully. Luckily, gromos 54 force field accepted calcium ion, I ran md for 50 ns. Waiting for the result, Sir.

Thank you so much for your reply. I will try as per your suggestions.

All of those force fields should support Ca2+ atoms, so without more detail about what went wrong, there’s not much to suggest. If you want to use GROMOS, at least use ATB for the ligand topology. But choosing a force field should not default to “this is the one I could make work,” it should be “this is the most suitable for the task at hand.” So doing your homework on how to fix errors when trying to use a given model is very important.

Ok sir. Thanks for your reply.