How to fix the error '[ atomtypes ]' Invalid order for directive atomtypes

GROMACS version:
GROMACS modification: Yes/No
Here post your question

I used a CHARMM-GUI ligand modeler and multicomponent assembler to generate a system consisting of one 4- charged EDTA ion, four Ca2+ ions, four Cl- ions, and solvated by water molecules. Since I couldn’t get the final file from the multicomponent assembler formatted in GROMACS, I combined all forcefields (4- charged EDTA ion, Ca2+ ions, Cl- ions, and tip3p) and put them together in a .itp file named “charmm36.itp”.

However, I still get an error of ‘[ atomtypes ]’ Invalid order for directive atomtypes.

I attached the file as a reference. (776 Bytes)

Thanks in advance.

If you search for the same error or look in the related threads below, you will find more help. The issue is that there may not be any [ atomtypes ] after the first [ moleculetype ] entry in the topology. From your it is not possible to see if there are any [ atomtypes ] sections in the included itp files (except charmm36.itp), but I suppose that there are.

But I admit it looks a bit strange, because even in the IEDTA.itp file it would be fine with an [ atomtypes ] section and for tip3p and the ions it should not be needed.