Reading a ions.mdp file

GROMACS version: 2020.2
GROMACS modification: Yes/No
Here post your question:

I created an ions.mdp text file however my iTerm is listing it as ions.mdp.txt not allowing me to run:
gmx grompp -f ions.mdp -c 1AKI_solv.gro -p topol.top -o ions.tpr

I used textedit1.15 and am getting the error:
Error in user input:
Invalid command-line options
In command-line option -f
File ‘ions.mdp’ does not exist or is not accessible.
The file could not be opened.
Reason: No such file or directory
(call to fopen() returned error code 2)

So I also tried changing my command to -f ions.mdp.txt and saved my text as ions.mdp.txt and am still getting an error:
Error in user input:
Invalid command-line options
In command-line option -f
File ‘ions.mdp.txt’ cannot be used by GROMACS because it does not have a
recognizable extension.
The following extensions are possible for this option:
.mdp

Finally I just changed my text edit to ions.mdp.txt to match the iTerm script and got this error:
Error in user input:
Invalid command-line options
In command-line option -f
File ‘ions.mdp’ does not exist or is not accessible.
The file could not be opened.
Reason: No such file or directory
(call to fopen() returned error code 2)

Suggestions on how to change my iTerm code to just ions.mdp?

Thanks:)
Joel

Make sure you save all files as plain text, not the default rich text. GROMACS utilities won’t be able to parse anything in an RTF-edited file. That’s not your issue here, just FYI.

This just means the file isn’t in the working directory, or does not have read permission.

Hello Justin and thank you for your kind update,

my iTerm is listing my mdp file as ions.mdp.txt I am imagining that this is why Gromacs is unable to read my ions.mdp text file. How would I make my iTerm read my text file as ions.mdp not ions.mdp.txt? This should solve the problem.

Thanks:)
Joel

Name the file ions.mdp. All GROMACS tools require known file extensions. You aren’t solving a missing ions.mdp file (original error) by renaming it ions.mdp.txt. If, for some reason, you do have ions.mdp.txt, you need to rename it ions.mdp to work.

Hello Justin and thank you for your kind direction, fixed (I simply needed to just check-off the add txt box in my textedit preferences, this was the problem (.txt was hidden when viewed)