Error when running NVT

GROMACS version: 2020
GROMACS modification: Yes/No
Here post your question- I have been attempting to do a Protein-Ligand simulation and ran into an error. When attempting to run energy minimization I got an error which read as follows

Step= 135, Dmax= 3.5e-06 nm, Epot= -1.54589e+06 Fmax= 6.16447e+04, atom= 3055
Step= 138, Dmax= 1.0e-06 nm, Epot= -1.54589e+06 Fmax= 8.09544e+04, atom= 3052
Energy minimization has stopped, but the forces have not converged to the
requested precision Fmax < 3000 (which may not be possible for your system).
It stopped because the algorithm tried to make a new step whose size was too
small, or there was no change in the energy since last step. Either way, we
regard the minimization as converged to within the available machine
precision, given your starting configuration and EM parameters.

Double precision normally gives you higher accuracy, but this is often not
needed for preparing to run molecular dynamics.
You might need to increase your constraint accuracy, or turn
off constraints altogether (set constraints = none in mdp file)

writing lowest energy coordinates.

Steepest Descents converged to machine precision in 139 steps,
but did not reach the requested Fmax < 3000.
Potential Energy = -1.5458921e+06
Maximum force = 6.1644723e+04 on atom 3055
Norm of force = 2.9756545e+02

I then modified the parameters of my em.mdp which I had originally found on the gromacs Protein-Ligand tutorial. I changed the emtol from 1000.0 to

emtol = 3700.0 ; Stop minimization when the maximum force < 10.0 kJ/mol

After this change I was able to go through energy minimization with no more errors albeit with lesser steps.

However once I got to the nvt portion of the simulation prep I ran into 2 errors. The first was

WARNING 1 [file, line 29067]:
** The following macros were defined in the ‘define’ mdp field with the -D**
** prefix, but were not used in the topology:**
** If you haven’t made a spelling error, either use the macro you defined,**
** or don’t define the macro**
Program: gmx grompp, version 2020
Source file: src/gromacs/gmxpreprocess/grompp.cpp (line 2352)

Fatal error:
Too many warnings (1).
If you are sure all warnings are harmless, use the -maxwarn option.

For more information and tips for troubleshooting, please check the GROMACS
website at Common Errors — GROMACS webpage documentation

I was able to circumvent this error with the -maxwarn -1 command. Then, I attempted to run the gmx mdrun -deffnm nvt but then got the following error

Step 123, time 0.246 (ps) LINCS WARNING
relative constraint deviation after LINCS:
rms 8674.941406, max 211003.656250 (between atoms 1957 and 1960)
bonds that rotated more than 30 degrees:
** atom 1 atom 2 angle previous, current, constraint length**
** 1953 1954 54.6 0.1090 1919.4373 0.1090**
** 1953 1955 122.8 0.1090 1923.2582 0.1090**
** 1953 1956 125.6 0.1090 1918.8947 0.1090**
** 1957 1958 90.0 0.5901 1.7997 0.1090**
** 1957 1959 90.0 0.1326 1.3213 0.1090**
** 1957 1960 51.8 0.4827 22999.5078 0.1090**
** 1312 1313 61.0 0.1090 0.1090 0.1090**
** 1314 1315 90.0 1.6216 0.4057 0.1090**
** 1314 1316 90.0 0.1180 1.1591 0.1090**
** 3055 3054 45.3 0.5832 0.0945 0.0945**
** 3053 3052 90.0 0.1162 0.1384 0.0945**

step 123: One or more water molecules can not be settled.
Check for bad contacts and/or reduce the timestep if appropriate.
Wrote pdb files with previous and current coordinates

Program: gmx mdrun, version 2020
Source file: src/gromacs/ewald/pme_redistribute.cpp (line 304)
MPI rank: 14 (out of 20)

Fatal error:
12 particles communicated to PME rank 2 are more than 2/3 times the cut-off
out of the domain decomposition cell of their charge group in dimension x.
This usually means that your system is not well equilibrated.

For more information and tips for troubleshooting, please check the GROMACS
website at Common Errors — GROMACS webpage documentation

How do I correct my files so that I will not run into these errors? Thank you for your help in advance!!

Regarding the error minimization step, check whether you can identify why the system isn’t minimizing to below the initial emtol. Try visualizing the system to see whether there are any issues with how the ligand and protein are setup that might be causing the maximum force to remain above that value, and also double check that no restraints are setup that could be causing that issue. If there is an issue preventing the algorithm from minimizing, it might cause errors later on in the actual simulation.

For the nvt step, the warning seems to suggest your topology doesn’t include the position restraint file (should look something like
; Include Position restraint file
#ifdef POSRES
#include “posre.itp”
The position restraints are needed for the nvt and npt step since these steps require the protein-ligand complex to be held still while it equilibrates with the rest of the system