Gas-phase MD simulations, switch off PME and Coulomb/Lennard-Jones cut-offs set to infinity

GROMACS version: 2022

I wish to perform gas-phase MD simulations on a large protein structure and monitor it at increasing temperatures. I have never done gas-phase simulations before, especially with GROMACS. I believe, for GPU-accelerated gas phase simulations in Gromacs, a Pseudo-PBC approach must be used.

How can I switch off PME? at which stage and which parameter I need to edit in order to switch it off. Also, how can the PBC box dimensions be increased to the maximum allowed value ? Coulomb and Lennard-Jones cutoffs also need to be set to large values? or can I make it infinite? If so, where (which file) can I input/edit these parameters. Any help will be greatly appreciated.


There is no special setting for vacuum simulation in GROMACS. You can perform a vacuum simulation by setting your protein in a very large box and running using an NVT ensemble.

The option ‘coulombtype’ in the mdp file allows you to define the setting for the electrostatic interaction (PME vs cut-off). Note that the non-bonded interaction setting usually is link to the force field parameterization, and usually biomolecule force fields are not parameterized for vacuum simulations.
Here a post on similar topic How to simulate protein in vacuum in Gromacs 2021.4
I hope it helps


Thanks for your kindly reply.

when simulate in vacuum, you mean I just need to put the protein in a very large box?
Should I add counter ions to neutralize the system?(If so, what types of atom should I select to be replaced with counter ions? there is only protein in the system, even no waters.)



when simulate in vacuum, you mean I just need to put the protein in a very large box?

Yes. I mean to set the protein in the center of a very large box (filled by nothing).


Hi Alevilla,

Thanks so much for your reply! It really cleared some doubts I had. I was trying the solution you provided for setting a large box for the protein and using NVT ensemble. But I believe for Gromacs 2022 version, some of these functionalities for vacuum simulation have been entirely removed Removed functionality — GROMACS 2022 documentation.

I am not sure why and what are the implications of it, sadly.


Formally, a vacuum simulation is done without periodic boundary condition (PBC), so that there is exactly one instance of the protein in the box. This is not possible anymore (cf. " vacuum conditions are not supported").

What is suggested is to use a periodic, but large box (compared to the cutoff length), such that while there are periodic copies of the protein due to the PBC, there are far away enough to not interact with the central box. This is equivalent to a vacuum simulation.

In both case, cutoff electrostatics is used instead of PME (mdp parameter coulombtype). In the first case, this is because Ewald-based methods require periodicity. In the second, using cutoff ensures there is exactly 0 interactions between the multiple copies of the protein, as desired.

Hi ebriand, Thanks for your patient reply and clarifying some of my doubts. When you say set a very large box, what is generally considered large enough? what dimensions can I use?

This is similar to choosing the box size for a normal simulation. There needs to be at least one cutoff length in all directions between the copies of the protein at all time to ensure the atoms of one copy do not see the atoms of the other copy. (see diagram). If this is satisfied, it is equivalent to a vacuum simulation.


Assuming your protein is relatively sphere-like, and keeps it shape during the simulation, that means there need to be at least half the cutoff distance between the protein edge and the box edge. The -d option of gmx editconf can help you there. As there is no impact on performance with cutoff electrostatics, you can put 2 or 3 time the cutoff between the protein and edge of box for peace of mind.

Thanks ebirand, this really helps! I have used 3 times the protein size as cutoff, and it seems to be working fine. Thanks for your prompt replies.