Problem with maintaining the Temperature of the system in NVE Production

GROMACS version: 5.0.4
Here post your question

I was trying to simulate a small organic system using Gromacs 5.0.4. My simulation goes on like i) Heating at 500K for 2ns, ii) Annealing the temperature from 500 to 330K within 2ns,
iii) Ran NPT simulation for 10ns after that iv) an NVT simulation for 10ns. After equilibrating the system I have performed an NVE production for a 50ns.
Now I am facing the problem with maintaining the Temperature of the system in NVE production. The temperature is increasing while i am increasing the run length. Please do modify my .mdp file or give any suggestions regarding my problem for which I shall be grateful. I am attaching the .mdp file for your reference. Please find

mdp file:
title = NVE Production
; Run parameters
integrator = md
nsteps = 10000000
dt = 0.001

; Output Control
nstlog = 2000
nstenergy = 2000
nstxout = 2000
nstvout = 2000
;nstxtcout = 0
nstfout = 2000

; Bond parameters
constraint_algorithm = lincs
constraints = h-bonds
lincs_iter = 2
lincs_order = 4

; Nonbonded settings
cutoff-scheme = Verlet
ns_type = grid
nstlist = 10
rlist = 1.2
vdwtype = cutoff
vdw-modifier = Potential-switch
rvdw-switch = 1.0
rvdw = 1.2

; Electrostatics
coulombtype = PME
rcoulomb = 1.2
pme_order = 4
fourierspacing = 0.16
DispCorr = EnerPres
; Temperature
Tcoupl = no
; Pressure
Pcoupl = no
; Initial Velocities
gen_vel = no
gen_temp = 330
gen_seed =-1

Temperature is not a conserved quantity in an NVE simulation, so you should expect it to change. Make sure you’re appropriately conserving energy by tracking the total energy over time. You may need to use double precision or higher order for LINCS.

Dear Sir,
I have plotted the energy of the corresponding system and i find the energy is not conserving. I am attaching the energy plot, please find it.
Now, I am running a job keeping LINCS order higher as you suggested.

Hi did changing the lincs order solve your issue? just wondering cause I’m getting the same issue.