How do I proceed with nvt mdrun step in GROMACS and solve the following error

[How do I solve the following error and proceed with nvt mdrun step in GROMACS (i have tried reducing timesteps, also tried putting define = -­DFLEXIBLE)
ERROR- starting mdrun ‘Protein in water’

50000 steps, 100.0 ps.

step 0

step 22: One or more water molecules can not be settled.

Check for bad contacts and/or reduce the timestep if appropriate.

Wrote pdb files with previous and current coordinates

[1] 15894 segmentation fault gmx mdrun -v -deffnm nvt


It would be hard tell what might be going wrong with this limited information.

Some suggestions:

  1. Check whether your initial configuration is reasonable. There should not be any bad contacts. Also molecules should be packed in accordance with overall density of the system.
  2. Check energies in your energy minimisation. The system should be energy minimised properly. If required do multiple energy minimizations.
  3. In worst case scenario, you need to check whether your protein itp is not problematic.


  1. The initial configuration is good (followed the same procedure as for the other molecules). Moreover, how to check for bad contacts and density?
  2. I have tried doing multiple energy minimizations, still getting the error.
  3. ITP file has been created using the Prodrg server and therefore I believe it should be fine.

Sir, I am using the same protein and procedures for 10 other ligands and I have just met with this error in only 1 ligand (I have tried this ligand with other proteins and getting the same error)

PRODRG topologies are demonstrably inappropriate for doing MD simulations. I thought its developer had taken it offline a long time ago. Never use PRODRG topologies.

If you need further help after using an appropriate topology, we will need far more information, including the exact output from mdrun energy minimization (maximum forces and energy) to give any useful help.

thanks a lot for your reply, I tried CGenFF to go ahead with this ligand and used charmm-36.jul2020.ff and script, but I am getting one error in the generation of the topology.

Residue ‘ZN’ not found in the residue topology database.

The residue name in CHARMM is ZN2, not ZN.

Sir, I tried putting ZN2 instead of ZN everywhere in my protein and then run the charmm, I got the following errors :-

Atom ZN2 in residue ZN2 201 was not found in rtp entry ZN2 with 1 atoms while sorting atom

The residue name is ZN2, the atom within the residue is ZN.

Sir, Thanks for your guidance, I have been able to resolve the error and my file and ligand.itp files are successfully made,
Sir, I am facing another error in solv.gro and proteinions.tpr steps: -

ERROR 1 [file 10.itp, line 237]:
No default U-B types
ERROR 2 [file 10.itp, line 337]:
No default Proper Dih. types

I have changed my files many times and tried with different commands but this issue is not resolved.