No SOL in

GROMACS version: 2020.4
GROMACS modification: No


I have created a simulation box containing two peptides, and added water molecules.
Then I tried neutralizing the system with ions, but I got this error:

No line with molecule type ‘SOL’ found the [molecules] section of file ‘’

The file does include the SOL and its number. I am not sure why I am getting this error.
Any help will be appreciated.

Have you ever opened the file with a non-plain text editor? Try running it through dos2unix to make sure you have correct line endings.

Thank you for your suggestion, and it worked nicely.
I had to move my files from a Linux computer in my lab to my Windows computer to create the system and modify .itp and .top files using Notepad ++.

After that, I moved the files to the Linux computer, and converted the file using dos2unix command. I guess the conversion is necessary because the way Windows modify the texts is different from the editors in Linux?

The important thing is to always use a plain text editor, like VIM or Emacs. Rich-text editors add hidden characters that break formatting. Most Windows programs will indeed break everything when trying to go back to a Linux system, because even the newline characters are different in the Windows OS.